prompt stringlengths 317 6.78k | task_name stringclasses 1
value | filepath stringlengths 81 170 | rule stringlengths 163 6.62k | description stringclasses 1
value | configuration stringclasses 1
value |
|---|---|---|---|---|---|
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule suspicious_command_line_contains_azure_tokencachedat_as_argument_via_cmdline {
events:
(re.regex($selection.target.process.command_line, `.*TokenCache\.dat.*`) and ($sel... | chronicle | /chronicle/detection-rules/soc_prime_rules/cloud_security/sysmon/suspicious_command_line_contains_azure_tokencache_dat_as_argument__via_cmdline.yaral | rule suspicious_command_line_contains_azure_tokencachedat_as_argument_via_cmdline {
events:
(re.regex($selection.target.process.command_line, `.*TokenCache\.dat.*`) and ($selection.metadata.product_event_type = "4688" or $selection.metadata.product_event_type = "1"))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule the_gocgle_malicious_campaign {
events:
(($selection.principal.hostname = "gocgle-analytics.net" or $selection.principal.hostname = "googlo-analytics.com" or $selection.... | chronicle | /chronicle/detection-rules/soc_prime_rules/cloud_security/proxy/the_gocgle_malicious_campaign.yaral | rule the_gocgle_malicious_campaign {
events:
(($selection.principal.hostname = "gocgle-analytics.net" or $selection.principal.hostname = "googlo-analytics.com" or $selection.principal.hostname = "gocgletagmanager.com" or $selection.principal.hostname = "googlc-analytics.com" or $selection.principal.hostname = "gocgle-... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule mshta_spwaned_by_svchost_as_seen_in_lethalhta_sysmon {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.principal.process.file.full_path, `.... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/mshta_spwaned_by_svchost_as_seen_in_lethalhta__sysmon.yaral | rule mshta_spwaned_by_svchost_as_seen_in_lethalhta_sysmon {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.principal.process.file.full_path, `.*\\svchost\.exe`) and re.regex($selection.target.process.command_line, `.*/mshta\.exe`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule powershell_download_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "powershell.exe" and (re.regex($selecti... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/powershell_download__sysmon.yaral | rule powershell_download_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "powershell.exe" and (re.regex($selection.target.process.command_line, `.*DownloadFile.*`) or re.regex($selection.target.process.command_line, `.*invoke-webrequest.*`) or re.regex($sel... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule olympic_destroyer_detector {
events:
(($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "9bc365a16c63f25dfddcbe11da042974" or $selection.ta... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/olympic_destroyer_detector.yaral | rule olympic_destroyer_detector {
events:
(($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "9bc365a16c63f25dfddcbe11da042974" or $selection.target.file.md5 = "da93e6651c5ba3e3e96f4ae2dd763d94" or $selection.target.file.md5 = "6ccd8133f250d4babefbd66b898739b9" or $selection.target.file.m... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule usb_file_stealer_usbguard_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "050EB7D20EE8EF1E1DAEE2F421E5BF648FB6... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/usb_file_stealer__usbguard__detector__sysmon.yaral | rule usb_file_stealer_usbguard_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "050EB7D20EE8EF1E1DAEE2F421E5BF648FB645DF" or $selection.target.file.md5 = "069A919B3BC8070BB2D71D3E1AD9F7642D8ECF0F" or $selection.target.file.md5 = "0D265E0BDA9DF83815759ABCA64938E... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule zebrocy_tool_apt28_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "7768fd2812ceff05db8f969a7bed1de5615bfc5a" or $select... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/zebrocy_tool_apt28__sysmon.yaral | rule zebrocy_tool_apt28_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "7768fd2812ceff05db8f969a7bed1de5615bfc5a" or $selection.target.file.md5 = "da70c54a8b9fd236793bb2ab3f8a50e6cd37e2df" or $selection.target.file.md5 = "a225d457c3396e647ffc710cd1edd4c74dc57152" or $s... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule schtask_creation_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "schtask.exe")
condition:
$selectio... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/schtask_creation__sysmon.yaral | rule schtask_creation_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "schtask.exe")
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule bcdedit_off_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "bcdedit.exe" and re.regex($selection.target.pr... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/bcdedit_off__sysmon.yaral | rule bcdedit_off_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "bcdedit.exe" and re.regex($selection.target.process.command_line, `.*off`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule pony_malware_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "2fdc22d8926db1b04dc3d62ff6da72236cb1c052b23553b644c7f18ea8... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/pony_malware__sysmon.yaral | rule pony_malware_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "2fdc22d8926db1b04dc3d62ff6da72236cb1c052b23553b644c7f18ea8496d8a" or $selection.target.file.md5 = "6bfa353f905c0fc5ded87e7f35dc939e7b757ea3f2f8372f81f0ac40edadd619" or $selection.target.file.md5 = "3f524... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule ta505_group_targets_the_us_retail_industry_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "9206f08916ab6f9708d81a6cf2f9... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/ta505_group_targets_the_us_retail_industry__sysmon.yaral | rule ta505_group_targets_the_us_retail_industry_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "9206f08916ab6f9708d81a6cf2f916e2f606fd048a6b2355a39db97e258d0883" or $selection.target.file.md5 = "06c637ac62cab511c5c42e142855ba0447a1c8ac8ee4b0f1f8b00faa5310fe9f" or $sele... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule ryuk_ransomware_detector_sysmon_behavior {
events:
($selection1.metadata.product_event_type = "11" and (re.regex($selection1.target.file.full_path, `.*\.ryk`) or $select... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/ryuk_ransomware_detector__sysmon_behavior.yaral | rule ryuk_ransomware_detector_sysmon_behavior {
events:
($selection1.metadata.product_event_type = "11" and (re.regex($selection1.target.file.full_path, `.*\.ryk`) or $selection1.target.file.full_path = "RyukReadMe.html"))
condition:
$selection1
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule netwalker_ransomware_detection {
events:
(re.regex($selection.target.process.file.full_path, `.*vssadmin\.exe`) and re.regex($selection.principal.process.file.full_path,... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/netwalker_ransomware_detection.yaral | rule netwalker_ransomware_detection {
events:
(re.regex($selection.target.process.file.full_path, `.*vssadmin\.exe`) and re.regex($selection.principal.process.file.full_path, `.*qeSw\.exe`) and $selection.target.process.command_line = "vssadmin.exe delete shadows /all /quiet")
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule keylogger_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "21921864D2F1AB2761C36031A2E1D2C00C9B304A" or $select... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/keylogger_detector__sysmon.yaral | rule keylogger_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "21921864D2F1AB2761C36031A2E1D2C00C9B304A" or $selection.target.file.md5 = "3C2D0615BEF6F88FED6E308D4F45B6133080C74F" or $selection.target.file.md5 = "91E8346910E0E6783ACFC4F2B9A745C81BD7573A"))
... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule hawkeye_keylogger_file_creation_and_create_process_detector_sysmon_behavior {
events:
(re.regex($selection1.target.process.file.full_path, `C:\\Windows\\Microsoft\.NET\\... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/hawkeye_keylogger_file_creation_and_create_process_detector__sysmon_behavior.yaral | rule hawkeye_keylogger_file_creation_and_create_process_detector_sysmon_behavior {
events:
(re.regex($selection1.target.process.file.full_path, `C:\\Windows\\Microsoft\.NET\\Framework.*\\vbc\.exe`) and (($selection1.metadata.product_event_type = "11" and re.regex($selection1.target.file.full_path, `C:\\Users.*\\AppDat... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule kingminer_cryptojacker_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "dea32433519c4628deeac802c0f1435a1b0d27d89f1ae5c1... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/kingminer_cryptojacker__sysmon.yaral | rule kingminer_cryptojacker_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "dea32433519c4628deeac802c0f1435a1b0d27d89f1ae5c1729ec7223f9eb04d" or $selection.target.file.md5 = "147d572d7f6664c8adf42ef92e4dbad06c5d21cc820a20163d814c77136cfbab" or $selection.target.file.md... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule turla_backdoor_sysmon {
events:
($selection_hashes.metadata.product_event_type = "1" and ($selection_hashes.target.file.md5 = "fd898c5a4cd57c3e9cef41f6fd4f71a7" or $sele... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/turla_backdoor__sysmon.yaral | rule turla_backdoor_sysmon {
events:
($selection_hashes.metadata.product_event_type = "1" and ($selection_hashes.target.file.md5 = "fd898c5a4cd57c3e9cef41f6fd4f71a7" or $selection_hashes.target.file.md5 = "9dab3dd7b7e7f4980397da908fbc9ff7" or $selection_hashes.target.file.md5 = "3eb5f44492ce1147790450d950954a52"))
... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule hworm_and_njrat_ratbackdoor_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "00df326eee18617fae2fdd3684ac1546" or $selec... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/hworm_and_njrat_rat_backdoor__sysmon.yaral | rule hworm_and_njrat_ratbackdoor_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "00df326eee18617fae2fdd3684ac1546" or $selection.target.file.md5 = "1488cdc5c5c9c87b4e0dae27ba3511cb" or $selection.target.file.md5 = "4543daa6936dde54dda8782b89d5daf1" or $selection.target... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule quasar_rat_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "0A4915B81D9A9ACF4E19181DEEEBBE244430C16B" or $selec... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/quasar_rat_detector__sysmon.yaral | rule quasar_rat_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "0A4915B81D9A9ACF4E19181DEEEBBE244430C16B" or $selection.target.file.md5 = "323160C88A254127D9ADB2848AE044AFFF376A4D" or $selection.target.file.md5 = "395166835495B418773C9690227779D592F94F71" or $... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule schtask_from_user_profile_sysmon {
events:
($selection.metadata.product_event_type = "1" and (re.regex($selection.target.process.file.full_path, `.*schtask\.exe`) or re.... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/schtask_from_user_profile__sysmon.yaral | rule schtask_from_user_profile_sysmon {
events:
($selection.metadata.product_event_type = "1" and (re.regex($selection.target.process.file.full_path, `.*schtask\.exe`) or re.regex($selection.target.process.file.full_path, `.*schtasks\.exe`)) and re.regex($selection.target.process.command_line, `.*\\appdata.*`))
con... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule wsfjsejsvbavbe_file_execution_sysmon {
events:
($selection.metadata.product_event_type = "1" and (re.regex($selection.target.process.file.full_path, `.*wscript\.exe`) or... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/wsf_jse_js_vba_vbe_file_execution__sysmon.yaral | rule wsfjsejsvbavbe_file_execution_sysmon {
events:
($selection.metadata.product_event_type = "1" and (re.regex($selection.target.process.file.full_path, `.*wscript\.exe`) or re.regex($selection.target.process.file.full_path, `.*cscript\.exe`)) and (re.regex($selection.target.process.command_line, `.*\.jse.*`) or re.r... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule net_ipc_share_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "net.exe" and re.regex($selection.target.proc... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/net_ipc_share__sysmon.yaral | rule net_ipc_share_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "net.exe" and re.regex($selection.target.process.command_line, `.*ipc$.*`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule vermin_backdoor_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "028EBDBEBAC7239B41A1F4CE8D2CC61B1E09983B" or $... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/vermin_backdoor_detector__sysmon.yaral | rule vermin_backdoor_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "028EBDBEBAC7239B41A1F4CE8D2CC61B1E09983B" or $selection.target.file.md5 = "07E1AF6D3F7B42D2E26DF12A217DEBACEDB8B1B9" or $selection.target.file.md5 = "09457ACB28C754AA419AB6A7E8B1940201EF3FFE"... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule zombieboy_cryptomining_worm_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "049fc01447f15e02fff88a2b10f1518c8489e97b2c2... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/zombieboy_cryptomining_worm__sysmon.yaral | rule zombieboy_cryptomining_worm_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "049fc01447f15e02fff88a2b10f1518c8489e97b2c26006b4962ff5005e460dc" or $selection.target.file.md5 = "22f105dc2e2574ba3ea2ac4152391ce3bbaaa415a9660c251638281bbc5e8f33" or $selection.target.fi... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule hidden_cobra_fastcash_malware_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "10ac312c8dd02e417dd24d53c99525c29d74dcbc8... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/hidden_cobra_fastcash_malware__sysmon.yaral | rule hidden_cobra_fastcash_malware_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "10ac312c8dd02e417dd24d53c99525c29d74dcbc84730351ad7a4e0a4b1a0eba" or $selection.target.file.md5 = "3a5ba44f140821849de2d82d5a137c3bb5a736130dddb86b296d94e6b421594c" or $selection.target.... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule powershell_encoded_command_sysmon {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*powershell\.exe`) and... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/powershell_encoded_command__sysmon.yaral | rule powershell_encoded_command_sysmon {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*powershell\.exe`) and (re.regex($selection.target.process.command_line, `.*base64.*`) or re.regex($selection.target.process.command_line, `.*-enc.*`) or re.regex($sel... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule danabot_trojan_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.file.md5 = "76A64FD17CD1E7C59B8BDE7AA9209854")
condition:
$sel... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/danabot_trojan__sysmon.yaral | rule danabot_trojan_sysmon {
events:
($selection.metadata.product_event_type = "1" and $selection.target.file.md5 = "76A64FD17CD1E7C59B8BDE7AA9209854")
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule bitsadmin_download_sysmon {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\bitsadmin\.exe`) and (re.re... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/bitsadmin_download__sysmon.yaral | rule bitsadmin_download_sysmon {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\bitsadmin\.exe`) and (re.regex($selection.target.process.command_line, `.*/transfer`) or re.regex($selection.target.process.command_line, `.*/download`)))
condition:
... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule suspicious_reconnaissance_activity_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.process.command_line = "net group \"domain admin... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/suspicious_reconnaissance_activity__sysmon.yaral | rule suspicious_reconnaissance_activity_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.process.command_line = "net group \"domain admins\" /domain" or $selection.target.process.command_line = "net localgroup administrators"))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule roma225_campaign_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "4211e091dfb33523d675d273bdc109ddecf4ee1c1f5f29e8c82b9d... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/roma225_campaign__sysmon.yaral | rule roma225_campaign_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "4211e091dfb33523d675d273bdc109ddecf4ee1c1f5f29e8c82b9d0344dbb6a1" or $selection.target.file.md5 = "e8a765ec824881e1e78defd7c011da735f3e3b954aaf93a4282b6455a1b9afcc" or $selection.target.file.md5 = "7... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule formbook_malware_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "d7f0f3fea2f9935c1dd7bda343ec1e3fb77457e68b16b9d51516a3... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/formbook_malware__sysmon.yaral | rule formbook_malware_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "d7f0f3fea2f9935c1dd7bda343ec1e3fb77457e68b16b9d51516a3d8c651d14f" or $selection.target.file.md5 = "05a945fc7a9eb4c9a4db8eb974333b3938c06d9299976075b2fc00a79cf0a129" or $selection.target.file.md5 = "9... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule password_stealer_pwdfetcher_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "2A5C9D4DAE5E53B2962FBE2B7FA8798A12... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/password_stealer__pwdfetcher__detector__sysmon.yaral | rule password_stealer_pwdfetcher_detector_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "2A5C9D4DAE5E53B2962FBE2B7FA8798A127BC9A6" or $selection.target.file.md5 = "9B1586766AF9885EF960F05F8606D1230B36AC15" or $selection.target.file.md5 = "A2F0D5AF81D93752CFF1CF1E8BB9E... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule mssql_server_backdoor_detection_vollgar {
events:
($selection.metadata.product_event_type = "11" and ($selection.target.file.full_path = "C:\\ProgramData\\wget.vbs" or r... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/ms_sql_server_backdoor_detection__vollgar.yaral | rule mssql_server_backdoor_detection_vollgar {
events:
($selection.metadata.product_event_type = "11" and ($selection.target.file.full_path = "C:\\ProgramData\\wget.vbs" or re.regex($selection.target.file.full_path, `.*\\SQLAGENTIDC\.exe`) or $selection.target.file.full_path = "C:\\RECYCLER\\wget.vbs" or $selection.ta... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule betabot_neurevt_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "b4576437f4b06d438a03a9f8f0776cde" or $selection.target.... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/betabot__neurevt___sysmon.yaral | rule betabot_neurevt_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "b4576437f4b06d438a03a9f8f0776cde" or $selection.target.file.md5 = "a0763d3332bb87595ed6303ab3cdb8fff7dd1e976ee161003a62316fea332941"))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule suspicious_svchost_process_sysmon {
events:
(($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "svchost.exe") and not ($select... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/windows/suspicious_svchost_process__sysmon.yaral | rule suspicious_svchost_process_sysmon {
events:
(($selection.metadata.product_event_type = "1" and $selection.target.process.file.full_path = "svchost.exe") and not ($selection.metadata.product_event_type = "1" and (re.regex($selection.target.process.command_line, `.*\\services\.exe`) or re.regex($selection.target.pr... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule fallout_rig_ek_delivers_raccoon_stealer {
events:
(((re.regex($selection1.target.process.file.full_path, `.*\\cvtres\.exe`) and re.regex($selection1.principal.process.fi... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/fallout_rig_ek_delivers_raccoon_stealer.yaral | rule fallout_rig_ek_delivers_raccoon_stealer {
events:
(((re.regex($selection1.target.process.file.full_path, `.*\\cvtres\.exe`) and re.regex($selection1.principal.process.file.full_path, `.*\\csc\.exe`)) or ($selection1.metadata.product_event_type = "1" and (re.regex($selection1.target.process.file.full_path, `.*\\cs... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule detects_malware_acrord32exe_execution_process {
events:
(($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\AcroRD... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/detects_malware_acrord32_exe_execution_process.yaral | rule detects_malware_acrord32exe_execution_process {
events:
(($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\AcroRD32\.exe`)) and not (re.regex($selection.target.process.file.full_path, `.*\\Adobe\\Acrobat Reader DC\\Reader\\AcroRD32\.exe`)))
condition:
... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule psexec_process_has_terminated {
events:
($selection.metadata.product_event_type = "5" and re.regex($selection.target.process.file.full_path, `.*\\psexec\.exe`))
condi... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/psexec_process_has_terminated.yaral | rule psexec_process_has_terminated {
events:
($selection.metadata.product_event_type = "5" and re.regex($selection.target.process.file.full_path, `.*\\psexec\.exe`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule modification_of_windows_defender_service_settings_sysmon {
events:
(($selection1.metadata.product_event_type = "13" and (re.regex($selection1.target.registry.registry_ke... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/modification_of_windows_defender_service_settings__sysmon.yaral | rule modification_of_windows_defender_service_settings_sysmon {
events:
(($selection1.metadata.product_event_type = "13" and (re.regex($selection1.target.registry.registry_key, `.*\\SYSTEM\\ControlSet001\\services\\WinDefend`) or re.regex($selection1.target.registry.registry_key, `.*SOFTWARE\\Policies\\Microsoft\\Wind... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule covid19_themed_malware_via_chm_file {
events:
(($selection1.target.process.file.full_path = "C:\\Windows\\System32\\cmd.exe" and $selection1.principal.process.file.full_... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/covid_19_themed_malware_via_chm_file.yaral | rule covid19_themed_malware_via_chm_file {
events:
(($selection1.target.process.file.full_path = "C:\\Windows\\System32\\cmd.exe" and $selection1.principal.process.file.full_path = "C:\\Windows\\hh.exe" and re.regex($selection1.target.process.command_line, `.*for %i in \(.*\.chm\) do \(hh -decompile %temp% %~i\)&&cmd ... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule trickbot_behaviour_privilege_escalation_attack {
events:
(($selection1.metadata.product_event_type = "11" and (re.regex($selection1.target.file.full_path, `.* .*\\Micros... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/trickbot_behaviour__privilege_escalation_attack.yaral | rule trickbot_behaviour_privilege_escalation_attack {
events:
(($selection1.metadata.product_event_type = "11" and (re.regex($selection1.target.file.full_path, `.* .*\\Microsoft\\Windows\\DRM.*`) or re.regex($selection1.target.file.full_path, `.* .*\\Microsoft\\Network\\Downloader.*`) or re.regex($selection1.target.fi... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule darkgate_cryptocurrency_mining_and_ransomware_campaign_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "3340013b0f00fe0c... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/darkgate_cryptocurrency_mining_and_ransomware_campaign__sysmon.yaral | rule darkgate_cryptocurrency_mining_and_ransomware_campaign_sysmon {
events:
($selection.metadata.product_event_type = "1" and ($selection.target.file.md5 = "3340013b0f00fe0c9e99411f722f8f3f0baf9ae4f40ac78796a6d4d694b46d7b" or $selection.target.file.md5 = "0c3ef20ede53efbe5eebca50171a589731a17037147102838bdb4a41c33f94... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule rig_ek_delivers_predator_the_thiefbot_ransomware {
events:
((((re.regex($selection1.target.process.file.full_path, `.*\\socks111atx\.exe`) and re.regex($selection1.princ... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/rig_ek_delivers_predator_the_thief_bot_ransomware.yaral | rule rig_ek_delivers_predator_the_thiefbot_ransomware {
events:
((((re.regex($selection1.target.process.file.full_path, `.*\\socks111atx\.exe`) and re.regex($selection1.principal.process.file.full_path, `.*\\radD8D54\.tmp\.exe`)) or ($selection1.metadata.product_event_type = "1" and re.regex($selection1.target.process... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule diskshadow_and_vshadow_launch_detection {
events:
(re.regex($selection1.principal.process.file.full_path, `.*\\vshadow\.exe`) or re.regex($selection1.principal.process.f... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/diskshadow_and_vshadow_launch_detection.yaral | rule diskshadow_and_vshadow_launch_detection {
events:
(re.regex($selection1.principal.process.file.full_path, `.*\\vshadow\.exe`) or re.regex($selection1.principal.process.file.full_path, `.*\\diskshadow\.exe`) or (re.regex($selection1.target.process.command_line, `.*vshadow\.exe -nw -exec=.*`) or re.regex($selection... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule apt28_zekapabzebrocycannon_implant_sysmonfirewallproxy_part2 {
events:
((((((((((((($selectionSysmon3_emanueledelucia.target.url = "https://beatguitar.com/n2qqsy/hpse0/s... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/apt28_zekapab_zebrocy_cannon_implant__sysmon_firewall_proxy___part_2.yaral | rule apt28_zekapabzebrocycannon_implant_sysmonfirewallproxy_part2 {
events:
((((((((((((($selectionSysmon3_emanueledelucia.target.url = "https://beatguitar.com/n2qqsy/hpse0/sy/yasfy8/msayzp/lw.sip/?n=vxl0bnijnmttnsficoq=" or $selectionSysmon3_emanueledelucia.target.url = "beatguitar.com" or $selectionSysmon3_emanueled... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule registry_explorer_tool_detector {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\RECmd\.exe`))
cond... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/registry_explorer_tool_detector.yaral | rule registry_explorer_tool_detector {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\RECmd\.exe`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule psexec_detector {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\PsExec\.exe`))
condition:
$sel... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/sysmon/psexec_detector.yaral | rule psexec_detector {
events:
($selection.metadata.product_event_type = "1" and re.regex($selection.target.process.file.full_path, `.*\\PsExec\.exe`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule remote_system_discovery__ping_sweep {
events:
($selection1.target.process.file.full_path = "ping.exe" and (re.regex($selection1.target.process.command_line, `.* for /l %... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/remote_system_discovery___ping_sweep.yaral | rule remote_system_discovery__ping_sweep {
events:
($selection1.target.process.file.full_path = "ping.exe" and (re.regex($selection1.target.process.command_line, `.* for /l %i in \(1,1,254\) do ping -n 1 -w 100 192\.168\.1\.%i .*`) or re.regex($selection1.target.process.command_line, `.*for /l %i in \(1,1,254\) do pin... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule wastedlocker_ransomware_hunting_initial_access_and_compromise {
events:
($selection1.target.process.file.full_path = "wscript.exe" and re.regex($selection1.target.proces... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/wastedlocker_ransomware_hunting__initial_access_and_compromise.yaral | rule wastedlocker_ransomware_hunting_initial_access_and_compromise {
events:
($selection1.target.process.file.full_path = "wscript.exe" and re.regex($selection1.target.process.command_line, `wscript\.exe C:\\Users.*\\AppData\\Local\\Temp\\Temp1_Chrome\.Update\.b343b0\.zip\\Chrome\.Update\.c9a747\.js`) and ($selection1... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule possible_privilege_escalation_attack_using_dllhostexe {
events:
(re.regex($selection.target.process.file.full_path, `.*dllhost\.exe`) and (re.regex($selection.target.pro... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/possible_privilege_escalation_attack_using_dllhost_exe.yaral | rule possible_privilege_escalation_attack_using_dllhostexe {
events:
(re.regex($selection.target.process.file.full_path, `.*dllhost\.exe`) and (re.regex($selection.target.process.command_line, `.*Windows\\.*\\DllHost\.exe /Processid:{3E5FC7F9-9A51-4367-9063-A120244FBEC7}.*`) or re.regex($selection.target.process.comma... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule apt10_behavior {
events:
(($selection1.metadata.product_event_type = "4688" or $selection1.metadata.product_event_type = "1") and (($selection1.target.process.file.full_... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/apt10_behavior.yaral | rule apt10_behavior {
events:
(($selection1.metadata.product_event_type = "4688" or $selection1.metadata.product_event_type = "1") and (($selection1.target.process.file.full_path = "cmd.exe" and (re.regex($selection1.target.process.command_line, `.*/c certutil -decode C:\\ProgramData\\padre1\.txt C:\\ProgramData.*\\GU... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule lazarus_attack_variant {
events:
(($selection1.metadata.product_event_type = "4688" or $selection1.metadata.product_event_type = "1") and (($selection1.target.process.fi... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/lazarus_attack_variant.yaral | rule lazarus_attack_variant {
events:
(($selection1.metadata.product_event_type = "4688" or $selection1.metadata.product_event_type = "1") and (($selection1.target.process.file.full_path = "move.exe" and ($selection1.target.process.command_line = "move \"c:\\perflogs\\1.dat\" \"c:\\programdata\\microsoft\\sqcsvc\\sqcs... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule wastedlocker_ransomware_hunting_credential_dumping {
events:
($selection1.target.process.file.full_path = "reg.exe" and ($selection1.target.process.command_line = "reg s... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/wastedlocker_ransomware_hunting__credential_dumping.yaral | rule wastedlocker_ransomware_hunting_credential_dumping {
events:
($selection1.target.process.file.full_path = "reg.exe" and ($selection1.target.process.command_line = "reg save HKLM\\SAM C:\\programdata\\SamBkup.hiv" or $selection1.target.process.command_line = "reg save HKLM\\SYSTEM C:\\programdata\\FileName.hiv") a... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule netwire_rat_detection_via_wscript {
events:
((re.regex($selection.target.process.file.full_path, `.*\\wscript\.exe`) and (re.regex($selection.target.process.command_line... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/netwire_rat_detection_via_wscript.yaral | rule netwire_rat_detection_via_wscript {
events:
((re.regex($selection.target.process.file.full_path, `.*\\wscript\.exe`) and (re.regex($selection.target.process.command_line, `.* C:\\Users\\.*\.vbs .*`) or re.regex($selection.target.process.command_line, `.* C:\\Users\\admin\\AppData\\.*\.vbs .*`) or re.regex($select... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule t1214__credentials_in_registry {
events:
($selection1.target.process.file.full_path = "reg.exe" and ($selection1.target.process.command_line = "reg query HKLM /f passwor... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/t1214___credentials_in_registry.yaral | rule t1214__credentials_in_registry {
events:
($selection1.target.process.file.full_path = "reg.exe" and ($selection1.target.process.command_line = "reg query HKLM /f password /t REG_SZ /s" or $selection1.target.process.command_line = "reg query HKCU /f password /t REG_SZ /s") and ($selection1.metadata.product_event_t... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule fileless_attack_via_regsvr32exe {
events:
(re.regex($selection.target.process.command_line, `.*regsvr32.*`) and ($selection.metadata.product_event_type = "4688" or $sele... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/fileless_attack_via_regsvr32_exe.yaral | rule fileless_attack_via_regsvr32exe {
events:
(re.regex($selection.target.process.command_line, `.*regsvr32.*`) and ($selection.metadata.product_event_type = "4688" or $selection.metadata.product_event_type = "1") and re.regex($selection.target.process.command_line, `.*/s.*`) and re.regex($selection.target.process.co... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule wastedlocker_ransomware_hunting_defense_evasion {
events:
(($selection1.metadata.product_event_type = "4688" or $selection1.metadata.product_event_type = "1") and ((($se... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/wastedlocker_ransomware_hunting__defense_evasion.yaral | rule wastedlocker_ransomware_hunting_defense_evasion {
events:
(($selection1.metadata.product_event_type = "4688" or $selection1.metadata.product_event_type = "1") and ((($selection1.target.process.file.full_path = "cvtres.exe" and re.regex($selection1.target.process.command_line, `.*cvtres\.exe /NOLOGO /READONLY /MAC... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule system_information_gathering_via_wmicexe {
events:
(re.regex($selection1.target.process.file.full_path, `.*wmic\.exe`) and (re.regex($selection1.target.process.command_l... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/process_creation/system_information_gathering_via_wmic_exe.yaral | rule system_information_gathering_via_wmicexe {
events:
(re.regex($selection1.target.process.file.full_path, `.*wmic\.exe`) and (re.regex($selection1.target.process.command_line, `.* .* DESKTOPMONITOR get pnpdeviceid .*`) or re.regex($selection1.target.process.command_line, `.* .* SOUNDDEV get pnpdeviceid .*`) or re.r... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule antivirus_password_dumper_detection {
events:
(re.regex($selection.target.registry.registry_value_data, `.*DumpCreds.*`) or re.regex($selection.target.registry.registry_... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/antivirus/antivirus_password_dumper_detection.yaral | rule antivirus_password_dumper_detection {
events:
(re.regex($selection.target.registry.registry_value_data, `.*DumpCreds.*`) or re.regex($selection.target.registry.registry_value_data, `.*Mimikatz.*`) or re.regex($selection.target.registry.registry_value_data, `.*PWCrack.*`) or $selection.target.registry.registry_val... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule solarwinds_backdoor_c2_host_name_detected_via_dns {
events:
(re.regex($selection.network.dns.questions.name, `.*avsvmcloud\.com`) or re.regex($selection.network.dns.ques... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/dns/solarwinds_backdoor_c2_host_name_detected___via_dns.yaral | rule solarwinds_backdoor_c2_host_name_detected_via_dns {
events:
(re.regex($selection.network.dns.questions.name, `.*avsvmcloud\.com`) or re.regex($selection.network.dns.questions.name, `.*databasegalore\.com`) or re.regex($selection.network.dns.questions.name, `.*deftsecurity\.com`) or re.regex($selection.network.dns... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule flawedammyy_rat_detection_proxy {
events:
(($selectionSRC.target.url = "chimachinenow.com" or $selectionSRC.target.url = "highlandfamily.org" or $selectionSRC.target.url... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/flawedammyy_rat_detection__proxy.yaral | rule flawedammyy_rat_detection_proxy {
events:
(($selectionSRC.target.url = "chimachinenow.com" or $selectionSRC.target.url = "highlandfamily.org" or $selectionSRC.target.url = "intra.cfecgcaquitaine.com" or $selectionSRC.target.url = "motifahsap.com" or $selectionSRC.target.url = "sittalhaphedver.com" or $selectionSR... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule njrat_ratbackdoor_proxy {
events:
($selectionURL.target.url = "http://ghancommercialbank.com/msn/newclient.exe" or $selectionURL.target.url = "http://f.top4top.net/p_366... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/njrat_rat_backdoor__proxy.yaral | rule njrat_ratbackdoor_proxy {
events:
($selectionURL.target.url = "http://ghancommercialbank.com/msn/newclient.exe" or $selectionURL.target.url = "http://f.top4top.net/p_3667b75e1.png" or $selectionURL.target.url = "http://f.top4top.net/p_42526hb61.png" or $selectionURL.target.url = "http://cdn.discordapp.com/attachm... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule detecting_phishing_domains_proxy {
events:
(($selection_URLs_1.target.url = "com-managers-updateds-notifications-accounts.com" or $selection_URLs_1.target.url = "com-upd... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/detecting_phishing_domains__proxy.yaral | rule detecting_phishing_domains_proxy {
events:
(($selection_URLs_1.target.url = "com-managers-updateds-notifications-accounts.com" or $selection_URLs_1.target.url = "com-updated-manager-notifications-accounts.info" or $selection_URLs_1.target.url = "com-index-managers-updateds-notifications-accounts.com" or $selectio... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule lojax_malware_proxyfirewall {
events:
(($SelectionSRC.principal.ip = "185.77.129.106" or $SelectionSRC.principal.ip = "185.144.82.239" or $SelectionSRC.principal.ip = "9... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/lojax_malware__proxy_firewall.yaral | rule lojax_malware_proxyfirewall {
events:
(($SelectionSRC.principal.ip = "185.77.129.106" or $SelectionSRC.principal.ip = "185.144.82.239" or $SelectionSRC.principal.ip = "93.113.131.103" or $SelectionSRC.principal.ip = "185.86.149.54" or $SelectionSRC.principal.ip = "185.86.151.104" or $SelectionSRC.principal.ip = "... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule solarwinds_backdoor_c2_host_name_detected_via_proxy {
events:
(re.regex($selection.target.hostname, `.*avsvmcloud\.com`) or re.regex($selection.target.hostname, `.*datab... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/solarwinds_backdoor_c2_host_name_detected___via_proxy.yaral | rule solarwinds_backdoor_c2_host_name_detected_via_proxy {
events:
(re.regex($selection.target.hostname, `.*avsvmcloud\.com`) or re.regex($selection.target.hostname, `.*databasegalore\.com`) or re.regex($selection.target.hostname, `.*deftsecurity\.com`) or re.regex($selection.target.hostname, `.*freescanonline\.com`) ... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule burp_suite_scanner_and_burp_collaborator_detected_via_proxy {
events:
re.regex($selection.target.url, `.*burpcollaborator.*`)
condition:
$selection
}
Output:
| chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/burp_suite_scanner_and_burp_collaborator_detected_via_proxy.yaral | rule burp_suite_scanner_and_burp_collaborator_detected_via_proxy {
events:
re.regex($selection.target.url, `.*burpcollaborator.*`)
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule detecting_gamaredon_groups_cc_servers_ip_addresses_and_domains_proxy {
events:
(($selection1.principal.ip = "95.142.45.86" or $selection1.principal.ip = "95.142.45.58" o... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/detecting_gamaredon_group_s_c_c_servers_ip_addresses_and_domains__proxy.yaral | rule detecting_gamaredon_groups_cc_servers_ip_addresses_and_domains_proxy {
events:
(($selection1.principal.ip = "95.142.45.86" or $selection1.principal.ip = "95.142.45.58" or $selection1.principal.ip = "95.142.45.57" or $selection1.principal.ip = "95.142.45.48" or $selection1.principal.ip = "95.142.45.44" or $selecti... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule yispecter_malware_detection {
events:
($selection.target.hostname = "bb800.com" or $selection.target.hostname = "ad.bb800.com" or $selection.target.hostname = "down.bb80... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/yispecter_malware_detection.yaral | rule yispecter_malware_detection {
events:
($selection.target.hostname = "bb800.com" or $selection.target.hostname = "ad.bb800.com" or $selection.target.hostname = "down.bb800.com" or $selection.target.hostname = "ty1.bb800.com" or $selection.target.hostname = "iosnoico.bb800.com" or $selection.target.hostname = "qvod... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule roma225_campaign_firewallproxy {
events:
(($SelectionSRC.principal.ip = "138.36.3.228" or $SelectionSRC.principal.ip = "184.75.209.169" or $SelectionSRC.principal.ip = "... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/roma225_campaign__firewall_proxy.yaral | rule roma225_campaign_firewallproxy {
events:
(($SelectionSRC.principal.ip = "138.36.3.228" or $SelectionSRC.principal.ip = "184.75.209.169" or $SelectionSRC.principal.ip = "177.85.98.242") or ($SelectionSRC.target.ip = "138.36.3.228" or $SelectionSRC.target.ip = "184.75.209.169" or $SelectionSRC.target.ip = "177.85.9... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule lojack_doubleagent_communication {
events:
($selection.target.hostname = "sysanalyticweb.com" or $selection.target.hostname = "elaxo.org" or $selection.target.hostname =... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/lojack_double_agent_communication.yaral | rule lojack_doubleagent_communication {
events:
($selection.target.hostname = "sysanalyticweb.com" or $selection.target.hostname = "elaxo.org" or $selection.target.hostname = "ikmtrust.com" or $selection.target.hostname = "lxwo.org")
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule sofacy__apt_c2_domain_communication {
events:
($selection.target.hostname = "myinvestgroup.com" or $selection.target.hostname = "netmediaresources.com" or $selection.tar... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/sofacy___apt_c2_domain_communication.yaral | rule sofacy__apt_c2_domain_communication {
events:
($selection.target.hostname = "myinvestgroup.com" or $selection.target.hostname = "netmediaresources.com" or $selection.target.hostname = "webviewres.net" or $selection.target.hostname = "adfs.senate.group" or $selection.target.hostname = "adfs-senate.email" or $selec... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule muddywater_apt_proxy {
events:
($selectionURL.target.url = "https://savephotos.net/e6N0RQ80" or $selectionURL.target.url = "http://sagawa-zz.com/sagawa.apk" or re.regex(... | chronicle | /chronicle/detection-rules/soc_prime_rules/ioc_sigma/proxy/muddywater_apt__proxy.yaral | rule muddywater_apt_proxy {
events:
($selectionURL.target.url = "https://savephotos.net/e6N0RQ80" or $selectionURL.target.url = "http://sagawa-zz.com/sagawa.apk" or re.regex($selectionURL.target.url, `http://59\.105\.6\.230//servlet/.*`) or $selectionURL.target.url = "http://118.160.115.74/admin/index.jsp")
conditi... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule suspicious_schtasks_creation_possible_windows_0day_lpe_aka_polarbear_by_sandboxescaper {
events:
(($selection.metadata.product_event_type = "1" or $selection.metadata.pr... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/microsoft_sysmon/suspicious_schtasks_creation__possible_windows_0day_lpe_aka__polarbear__by_sandboxescaper.yaral | rule suspicious_schtasks_creation_possible_windows_0day_lpe_aka_polarbear_by_sandboxescaper {
events:
(($selection.metadata.product_event_type = "1" or $selection.metadata.product_event_type = "4688") and $selection.target.process.command_line = "schtasks" and $selection.target.process.command_line = "/change" and $se... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule possible_abusing_ads {
events:
(re.regex($selection0.target.process.file.full_path, `.*:.*`) or re.regex($selection0.principal.process.file.full_path, `.*:.*`))
condi... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/microsoft_sysmon/possible_abusing_ads.yaral | rule possible_abusing_ads {
events:
(re.regex($selection0.target.process.file.full_path, `.*:.*`) or re.regex($selection0.principal.process.file.full_path, `.*:.*`))
condition:
$selection0
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule netsh_rdp_port_forwarding {
events:
(re.regex($selection.target.process.command_line, `netsh i.* p.*=3389 c.*`) and ($selection.metadata.product_event_type = "4688" or $... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/microsoft_sysmon/netsh_rdp_port_forwarding.yaral | rule netsh_rdp_port_forwarding {
events:
(re.regex($selection.target.process.command_line, `netsh i.* p.*=3389 c.*`) and ($selection.metadata.product_event_type = "4688" or $selection.metadata.product_event_type = "1"))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule fireeye_red_team_tool__execavatorexe_via_registry {
events:
($selection.metadata.event_type = "SetValue" and re.regex($selection.target.registry.registry_key, `.*Current... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/registry_event/fireeye_red_team_tool___execavator_exe__via_registry.yaral | rule fireeye_red_team_tool__execavatorexe_via_registry {
events:
($selection.metadata.event_type = "SetValue" and re.regex($selection.target.registry.registry_key, `.*CurrentControlSet\\services\\iphlpsvc6\\ImagePath`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule fireeye_red_team_tool__modified_impacket_smbexec_via_registry {
events:
((re.regex($selection1.target.registry.registry_key, `.*ImagePath.*`) and re.regex($selection1.me... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/registry_event/fireeye_red_team_tool___modified_impacket_smbexec__via_registry.yaral | rule fireeye_red_team_tool__modified_impacket_smbexec_via_registry {
events:
((re.regex($selection1.target.registry.registry_key, `.*ImagePath.*`) and re.regex($selection1.metadata.description, `.*%COMSPEC%.*`) and re.regex($selection1.metadata.description, `.*/q.*`) and re.regex($selection1.metadata.description, `.*/... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule malicious_service_installations {
events:
($selection.metadata.product_event_type = "7045" and (($selection.target.process.command_line = "WCESERVICE" or $selection.targ... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/malicious_service_installations.yaral | rule malicious_service_installations {
events:
($selection.metadata.product_event_type = "7045" and (($selection.target.process.command_line = "WCESERVICE" or $selection.target.process.command_line = "WCE SERVICE") or re.regex($selection.target.process.command_line, `.*\\PAExec.*`) or re.regex($selection.target.proces... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule password_dumper_activity_on_lsass {
events:
($selection.metadata.product_event_type = "4656" and $selection.target.process.file.full_path = "C:\\Windows\\System32\\lsass... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/password_dumper_activity_on_lsass.yaral | rule password_dumper_activity_on_lsass {
events:
($selection.metadata.product_event_type = "4656" and $selection.target.process.file.full_path = "C:\\Windows\\System32\\lsass.exe" and $selection.target.process.access_mask = "0x705" and $selection.principal.user.user_display_name = "SAM_DOMAIN")
condition:
$sele... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule possible_system_owneruser_discovery_sysmonwindows_logs {
events:
(($selection0.target.process.command_line = "wmic" or $selection0.target.process.command_line = "useracc... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/possible_system_owner_user_discovery__sysmon_windows_logs.yaral | rule possible_system_owneruser_discovery_sysmonwindows_logs {
events:
(($selection0.target.process.command_line = "wmic" or $selection0.target.process.command_line = "useraccount get /ALL" or $selection0.target.process.command_line = "whoami") or ($selection0.target.process.file.full_path = "whoami.exe" or $selection0... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule suspicious_psexec_execution {
events:
(($selection1.metadata.product_event_type = "5145" and re.regex($selection1.target.resource.name, `.*\\IPC$`) and (re.regex($select... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/suspicious_psexec_execution.yaral | rule suspicious_psexec_execution {
events:
(($selection1.metadata.product_event_type = "5145" and re.regex($selection1.target.resource.name, `.*\\IPC$`) and (re.regex($selection1.target.file.full_path, `.*-stdin`) or re.regex($selection1.target.file.full_path, `.*-stdout`) or re.regex($selection1.target.file.full_path... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule ad_privileged_users_or_groups_reconnaissance {
events:
($selection.metadata.product_event_type = "4661" and ($selection.principal.user.user_display_name = "SAM_USER" or ... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/ad_privileged_users_or_groups_reconnaissance.yaral | rule ad_privileged_users_or_groups_reconnaissance {
events:
($selection.metadata.product_event_type = "4661" and ($selection.principal.user.user_display_name = "SAM_USER" or $selection.principal.user.user_display_name = "SAM_GROUP") and ((re.regex($selection.target.registry.registry_value_data, `.*-512`) or re.regex($... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule admin_user_rdp {
events:
($selection.metadata.product_event_type = "4624" and $selection.extensions.auth.mechanism = "10" and $selection.principal.application = "Negotia... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/admin_user_rdp.yaral | rule admin_user_rdp {
events:
($selection.metadata.product_event_type = "4624" and $selection.extensions.auth.mechanism = "10" and $selection.principal.application = "Negotiate" and re.regex($selection.principal.user.user_display_name, `Admin-.*`))
condition:
$selection
}
| yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule guildma_malware_detector_sysmon_behavior {
events:
(($selection1.metadata.product_event_type = "11" and (re.regex($selection1.target.file.full_path, `C:\\Users\\Public\\... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/guildma_malware_detector__sysmon_behavior.yaral | rule guildma_malware_detector_sysmon_behavior {
events:
(($selection1.metadata.product_event_type = "11" and (re.regex($selection1.target.file.full_path, `C:\\Users\\Public\\Librarires\\awsvideos.*`) or re.regex($selection1.target.file.full_path, `C:\\Users \\Public\\Librarires\\awsvideos.*`) or re.regex($selection1.t... | yaral | |
Input: Translate the following yaral configuration for chronicle detection rules into concise natural language instructions for rule generation:
rule apt29 {
events:
(re.regex($selection.target.process.command_line, `.*-noni -ep bypass $.*`) and ($selection.metadata.product_event_type = "4688" or $selection.metadata.... | chronicle | /chronicle/detection-rules/soc_prime_rules/threat_hunting/windows/apt29_part_1.yaral | rule apt29 {
events:
(re.regex($selection.target.process.command_line, `.*-noni -ep bypass $.*`) and ($selection.metadata.product_event_type = "4688" or $selection.metadata.product_event_type = "1"))
condition:
$selection
}
| yaral |
End of preview. Expand in Data Studio
- Downloads last month
- 2